(877) 456-7632 info@msxgroup.com
Message Boards
Sign up Latest Topics
 
 
 


Reply
  Author   Comment   Page 1 of 2      1   2   Next
Noah.Moseley

Moderator
Registered:
Posts: 109
Reply with quote  #1 

On the Web login page for Forecaster 7.0, the login web page opens fine. Windows Authentication does not work. It states that

"Microsoft Forecaster Web Access could not log you on. Make sure your User Name and password are correct. Letters in passwords must be typed using the correct case. Make sure that Caps Lock is not accidentally on."
 
When selecting Windows Authentication, the Windows user domain and password does not appear in the user box. User and password remain blank.
 
Ideas?

 


__________________
Noah C. Moseley
MSX Group Senior Consultant and Certified Instructor
Noah.Moseley@MSXGroup.com
http://www.MSXGroup.com

Email me if you need help installing, implementing or just need training on Microsoft Forecaster, Management Reporter or FRx. Plus, Prospero for Financial Reporting and Budgeting is now available. See our introductory video at http://msxgroup.com/prospero_video_introduction

Management Reporter | Prospero | Forecaster | FRx
Training | Consulting Services | Software Support
Rob.Diaz

Moderator
Registered:
Posts: 87
Reply with quote  #2 
Forecaster Web Access does not fill in the username field when you choose Windows Authentication as the login method, so that's normal.

If you are able to login with this user using Windows Authentication via the full Forecaster client, the likely issue is a configuration problem on the server.  I don't know what version of IIS you are using, so I'll give you general instructions.

If you are using IIS 6 or earlier, go to the IIS manager on the web server, open the website list and select the Forecaster website (under the default site).  Right click on Forecaster and choose properties.  On the Directory Security tab, click the Edit button in the "Anonymous access and authentication control" category.  On the Authentication Methods window, UNCHECK the box for Anonymous access.  CHECK the box for Integrated Windows authentication.  NOTE:  If you are using a two-server install for Forecaster Web Access (in other words, the web server is a separate machine from the database server, you must enable BASIC authentication and users will be prompted to enter their windows credentials when attempting to log in.  This is an IIS requirement, not Forecaster Web Access).

If you are using IIS 7 or later, you need to enable the Basic Authentication option by going to the "Turn windows features on and off" applet, either by using the programs and features applet or via the server manager.  Go to the Internet Information Services feature and expand it.  Open the Security feature and check the box for Basic Authentication.  Click OK and wait for the feature to install.  Once installed, launch the Internet Information Services applet and navigate to the Forecaster website.  Under "Authentication", enable Basic Authentication and disable Anonymous Authentication.

You may have to restart IIS to make this work, but usually this is not required.  You MUST restart the client internet explorer.

Let me know if this helps or if there are further questions.


__________________
Rob Diaz
MSX Group
http://www.msxgroup.com
Noah.Moseley

Moderator
Registered:
Posts: 109
Reply with quote  #3 

This worked like a charm. Thanks Rob! You are brilliant!


__________________
Noah C. Moseley
MSX Group Senior Consultant and Certified Instructor
Noah.Moseley@MSXGroup.com
http://www.MSXGroup.com

Email me if you need help installing, implementing or just need training on Microsoft Forecaster, Management Reporter or FRx. Plus, Prospero for Financial Reporting and Budgeting is now available. See our introductory video at http://msxgroup.com/prospero_video_introduction

Management Reporter | Prospero | Forecaster | FRx
Training | Consulting Services | Software Support
aparna_patil

Registered:
Posts: 3
Reply with quote  #4 
Hi Rob,

We tried all the above solution for IIS, but still the problem exists .
IIS version - 5.1, Forecaster version 7.0 - SP3 and hotfix4 applied.

when the Forecaster site is opened it pops up the domain authentication dialog. After that the Forecaster site opens, when we selct Windows Authentication- the UserName and Password textbox are blank and disabled. Due to which can not enter domain username and password. If we try to login with blank UserName and Password , it does not login.

error as follows---
Microsoft Forecaster Web Access could not log you on. Make sure your User Name and password are correct. Letters in passwords must be typed using the correct case. Make sure that Caps Lock is not accidentally on.

Rob.Diaz

Moderator
Registered:
Posts: 87
Reply with quote  #5 

I'd be glad to try to help troubleshoot this for you.

Can a Forecaster administrator login successfully via Forecaster Web Access?  Are you using a database Role or an application role within SQL Server for Forecaster?  Can the user(s) having trouble login successfully via windows authentication using the full Forecaster client?  Is the SQL Server on the same machine as the Web server or is it a separate machine?  If it is two separate machines, have you made sure to enable only BASIC authentication, disabling anonymous and any other authentication method?


Have the Web Access client components downloaded and installed properly?  You can see this in the client workstations Add/remove programs applet -- there should be a Forecaster Web Access Client entry.

Finally, make sure that the URL the users are going to is simply:

https://servername/Forecaster

where "servername" is the address of your web server and "Forecaster" is whatever name you gave to the Forecaster Web Access site.  If you have anything following that site name, remove it from the shortcut and try again.

If you can answer these questions for me, I can help narrow down the issue for you.

Awaiting your reply,



__________________
Rob Diaz
MSX Group
http://www.msxgroup.com
aparna_patil

Registered:
Posts: 3
Reply with quote  #6 
1) A Forecaster administrator can not login via Forecaster Web Access using Windows Authentication, but the user is able to login via Forecaster Web Access by using standard authentication.
2) Using a database Role a within SQL Server for Forecaster. We have added a User with Windows Authentication on the Database. (with permission as Forecaster, db_owner and public)
3)SQL server is on different machine.
4)We tried enabling only basic authentication for the website does not work
5)Yes web access is installed properly and seen in add/remove pgms

We tried with https://servername/Forecaster It still doesn't work.Any inputs on the issue would be a great help.Thanks in advance
Rob.Diaz

Moderator
Registered:
Posts: 87
Reply with quote  #7 

Is the windows user able to login from the full Forecaster client?


__________________
Rob Diaz
MSX Group
http://www.msxgroup.com
aparna_patil

Registered:
Posts: 3
Reply with quote  #8 
yes, the windows user is able to login from the full Forecaster client. (rich Forecaster client) but only the windows user who has installed the Forecaster client.
When the Authentication type is selected as "Windows Authentication", the Username is filled with the windows user who has installed the Forecaster client  , also the Username and password textboxes are disabled, so we can login to full Forecaster client only with windows user who has installed the Forecaster client.
Rob.Diaz

Moderator
Registered:
Posts: 87
Reply with quote  #9 
I thought I had already responded to this but either I didn't or it got lost.

Has there been any further action on your part?

Please keep in mind that Windows Authentication implies that only the currently logged in Windows user can log in to Forecaster.  This is why the username/password boxes are disabled -- by choosing Windows Authentication on the drop down box, you are telling Forecaster to login as the person currently using the computer.  If another user needs to log in, they have to log into Windows first, then they can use Windows Authentication within Forecaster.

You said you added a Windows user in the SQL Server database -- I am assuming it is the same windows user you are trying to log in with in Forecaster Web Access?

__________________
Rob Diaz
MSX Group
http://www.msxgroup.com
sandeepnair

Registered:
Posts: 3
Reply with quote  #10 
Hi Rob,

i realize this is an old post, but i came across this issue today and none of the authetication options works. We use Forecaster 7 with Sp4 on a 64bit Windows Server 2008 and SQL 2008 R2 - Single server install. I am able to successfully login using the full client, but the web access always fails with the error -
Microsoft Forecaster Web Access could not log you on. Make sure your User Name and password are correct. Letters in passwords must be typed using the correct case. Make sure that Caps Lock is not accidentally on.

Any thoughts on what else i can look at?
 
Thanks,
 
Sandeep.
Rob.Diaz

Moderator
Registered:
Posts: 87
Reply with quote  #11 
Hi Sandeep,

To help you, we'd need to know what, exactly, you've tried.  If you are on a single server, you need to disable Anonymous authentication and enable only Windows Authentication. 

In addition, since you are running on a 64-bit server, you must also enable 32-bit applications.  To do this, go to IIS Manager, open up the application pools folder, find the Microsoft Forecaster app pool, right click on it and choose advanced properties.  There should be an option called "Enable 32-bit Applications". Set this value to True.

You may need to restart IIS for these changes to take effect. You certainly must close and reopen your internet explorer  sessions for these options to take effect as well.

I hope this helps.  Let us know how this proceeds.

-Rob

__________________
Rob Diaz
MSX Group
http://www.msxgroup.com
sandeepnair

Registered:
Posts: 3
Reply with quote  #12 
Hi Rob,

Thanks! I think the issue was that i had enabled "Basic Authentication" as well as "Windows". "Anonymous" was disabled for this web application but was enabled at the root "Default Website". I disabled everything except "Windows Authentication" for the default webbsite and the forecaster sub-site and tried and it works!

Thanks again for your guidance.

Sandeep.
David

Registered:
Posts: 1
Reply with quote  #13 
Sorry to post on such an old topic but I'm having the same issue and don't seem to be able to get around it.

SQL and IIS are separate servers.
SQL is SQL 2008 R2
IIS is v6.1 64bit o/s
Forecaster is 7 SP5

I have the full client of forecaster installed and have a windows user and a SQL user who can log in and use the full forecaster client.  Both are set in SQL as dbo and Forecaster roles against the forecaster database.

I have installed the web application and using the same windows user and SQL user (I’ve done it with both just to check) I have connected the website to the Forecaster web app using the database registration tool successfully.

The installation Forecaster has NOT been put in the default website as it was already in use by another application.

The Forecaster application pool has been changed to enable 32bit applications.

The website and the application page level have been changed to use Basic Authentication only.  All others have been disabled.

When opening the page the windows authentication pops up and I enter my credentials and arrive at the Forecaster Web Access Login screen.

At the login screen I try to enter the same credentials that get me into the full client and I get the message:

Microsoft Forecaster Web Access could not log you on.  Make sure your User Name and password are correct.  Letters in passwords must be typed using the correct case.  Make sure that the Caps Lock is not accidentally on.

Any thoughts on what I might have missed greatly appreciated.

 

Rob.Diaz

Moderator
Registered:
Posts: 87
Reply with quote  #14 

Hi David,

I'm going to have to ask a few questions to try to help:

You said you are using Forecaster SP5 with IIS v6.1.  I haven't heard of IIS 6.1.  What Server OS are you running? 

If you are running IIS 6, this is on Windows 2003 server and you may be falling prey to issue 489618: http://support.microsoft.com/kb/2828728

I don't think the web server actually has the issue that causes it to fail but this does complicate troubleshooting efforts because you can't test the main client or the web client from the same server.

Have you been attempting to test from the web server or from a client workstation? If a client workstation, what OS is being used? Can you confirm that the FCWA client components have updated on that machine? You can check by going to the Programs and Features applet of the Windows Control Panel and looking for "Microsoft Forecaster 7.0 Web Client Service Pack 5".

In your Internet Explorer session, do you see any error or warning down at the bottom of the page?

Are you using a 32-bit version of IE on the client?  Forecaster Web Access will not run in 64-bit IE.

Just in case the client hasn't updated, you can try the following:

Run IE 'As Administrator', by right-clicking on the IE icon and choosing 'Run as Administrator'.  Then make sure your URL is ONLY:  http://websitename -- in other words, do not include 'forecaster.asp' at the end. If there is an update, it will check for it and download it only from the default landing page.

Let us know about the above questions and we'll try to assist further.


__________________
Rob Diaz
MSX Group
http://www.msxgroup.com
jimosity

Registered:
Posts: 4
Reply with quote  #15 

I realize this is resurrecting a thread that's a couple years old -- but I'm running into exactly the same issue that has been discussed.

 

We're upgrading from 2003 servers to 2008 servers running IIS 6.1 (2008 R2 Enterprise servers).  The IIS server and the database servers are separate.

I have the new Forecaster application installed; verified that ports are configured correctly - I can connect to the database with an ODBC connection and I have the database registration tool configured right -- Yes, I've tried the fully qualified domain name for the server - it tests successfully.

I've gone through all suggestions on this site as well as all of the steps in this article.
https://support.microsoft.com/en-us/kb/2621460

Unfortunately, none of the suggestions (some of which have worked for others) have been successful for me.

The account that I've got the database registered with and that I'm trying to run the application with is a dbo.

Neither running the app itself or accessing thru the url works with the dbo user.

Any suggestions?

 

 

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.