(877) 456-7632 info@msxgroup.com
Message Boards
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
Rob.Diaz

Moderator
Registered:
Posts: 88
Reply with quote  #1 

If you are attempting to run the Forecaster Database Wizard against a SQL Server 2008 server, you may run into an error message stating that the Database Wizard cannot connect to the server.  Other tools, including ODBC and even Forecaster itself, can successfully connect.

Let me make it clear:  Microsoft Forecaster, the Forecaster Database Wizard, the Excel Add-in, ExpressLink, Forecaster Web Access and all other parts of the Microsoft Forecaster 7.0 product line work with Microsoft SQL Server 2008.

The trouble with the Database Wizard, though, is two-fold. 

First, the Forecaster Database Wizard is coded to work only with the Microsoft SQL Server 2005 versions of the Native Client and Management Objects.  Forecaster's installation program ships with the RTM version of SQL Server 2005's Native Client and Management Objects (a subsequent service pack updates these to the SP1 version). 

Second, there is a bug in the Microsoft SQL Server 2005 Native Client and Management Objects Collection which prevents tools from connecting to SQL Server 2008 database servers.  This bug was fixed in Microsoft SQL Server 2005 Service Pack 3.

To resolve the connectivity issue between Forecaster 7.0's Database Wizard and Microsoft SQL Server 2008 databases, you must install a SQL Server patch on any workstations or servers on which you intend to run the Database Wizard.

Download and install the latest version of the SQL Server 2005 Native Client and the SQL Server 2005 Management Objects Collection.  You can get these here:

http://www.microsoft.com/download/en/details.aspx?id=20101

Again, the only things you need to install to resolve this issue with the database wizard are the Microsoft SQL Server Native Client and the Microsoft SQL Server 2005 Management Objects CollectionYou do not need to install the entire SQL Server Service Pack 3 or 4 to the workstations.


Please note that this update is only required for the Forecaster Database Wizard.  Forecaster itself can work with the SQL Server 2008 Native Client and therefore does not suffer any consequences from this bug in SQL Server.

Additional Note: If you are using Microsoft Forecaster 7 Service Pack 4, you may not need to do this. Please follow the instructions in the following note before installing the items referenced here.

 
http://boards.msxgroup.com/post?id=5459996

__________________
Rob Diaz
MSX Group
http://www.msxgroup.com
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.